Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

  • Best Of...
  • Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

    We are excited to announce that a full Forum system upgrade is under way, which will make it even easier to get answers to your questions, help other owners by using your boating experience, and receive dependable advice from our network of experts. While things may look and operate a little differently, we believe the new system will ultimately improve your Forum Member experience.

    We are doing everything we can to transition your account smoothly without you having to change your current login, username or password. You should be able to get into your account exactly the same way once the transition takes place. However, if you have any questions or comments, please leave a comment in the General Discussions category.

    We look forward to sharing new features with you as we upgrade and improve your Owner's Club Forum experience!

    2013 40Hp Mercury Bigfoot 4 stroke issue

    fishbytefishbyte Member Posts: 3
    Have this engine on an 18 foot Sweatwater pontoon, been having issues with the engine running rough when below 1500 rpm.  Have changed out the fuel filter, plugs and new gas but still have the issue.  It does have the Delphi Carbon canister in the fuel delivery system, could this be causing the issue?  How often should the canister be replaced or is it even needed?
    Thanks 
    Sign In or Register to comment.