Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

  • Best Of...
  • Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

    We are excited to announce that a full Forum system upgrade is under way, which will make it even easier to get answers to your questions, help other owners by using your boating experience, and receive dependable advice from our network of experts. While things may look and operate a little differently, we believe the new system will ultimately improve your Forum Member experience.

    We are doing everything we can to transition your account smoothly without you having to change your current login, username or password. You should be able to get into your account exactly the same way once the transition takes place. However, if you have any questions or comments, please leave a comment in the General Discussions category.

    We look forward to sharing new features with you as we upgrade and improve your Owner's Club Forum experience!

    Newbie Question - No Power in 2002 Aqua Patio

    TroyNye71TroyNye71 USAMember Posts: 1
    Other day we were puttering around in the water and the boat just stopped running.  Afterwards, no start, no power in the console (except the horn) and the motor will not raise or lower (either from the console or the motor itself).  Checked the usual suspects (Battery, Fuses, & even replaced a Relay under the console).  Still stumped here.

    Wondering if it could be the kill switch, but for the life of me I can not remember ever having a "dead mans" lanyard attached to the ignition. 

    Hoping someone can shed some light.

    Thanks!

    Troy
    Sign In or Register to comment.