Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

  • Best Of...
  • Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

    We are excited to announce that a full Forum system upgrade is under way, which will make it even easier to get answers to your questions, help other owners by using your boating experience, and receive dependable advice from our network of experts. While things may look and operate a little differently, we believe the new system will ultimately improve your Forum Member experience.

    We are doing everything we can to transition your account smoothly without you having to change your current login, username or password. You should be able to get into your account exactly the same way once the transition takes place. However, if you have any questions or comments, please leave a comment in the General Discussions category.

    We look forward to sharing new features with you as we upgrade and improve your Owner's Club Forum experience!

    Electrical issue - 2008 Aqua Patio

    ClaudKClaudK USAMember Posts: 2
    I have a 2008 Aqua Patio. The motor will start.  The master power switch lights up.  I have no power to the dashboard, no nav lights, no radio, etc.  Is this a fuse issue?  Possible wire eaten thru?  Where are the fuses located?  Is there a wiring diagram?

    Comments

    • ClaudKClaudK USAMember Posts: 2
      The problem was resolved by replacing a relay switch under the dash.  Part was purchased at an auto parts store for about $10.
    • carguybillcarguybill USAMember Posts: 35 ✭✭
      Glad you found the issue and got it fixed. Enjoy your boating season.
      Bill Brown
      Sweetwater 2086BF
      Home: Coshocton, OH
      Boating: Cold Stream Pond, ME
    • FranzFranz Member Posts: 4
      I have the same problem with my 2004 AP in that the power switch lights up and the horn works but nothing else!!!
    • FranzFranz Member Posts: 4
      I also for $14.00 installed a R02 SH049 and now everything works<<<<Thank You carguybill!!!!!!!
    • FranzFranz Member Posts: 4
      Franz said:
      I also for $14.00 installed a R02 SH049 and now everything works<<<<Thank You ClaudK!!!!!!!

    Sign In or Register to comment.