Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

Brand new!!! But, is it a lemon?

Took delivery of 2019 SW2086C on Friday, 7-12-19. It was the first day of two week vacation. Boat went back to dealer on 7-16-19! It barely made the first 10 hours of break in period and we were very careful with it. Stalled several times and finally stalled in middle of lake and would not restart. Dealer says it may be fuel delivery problems. Today is 7-18-19, my wedding anniversary. Sad!
Dealer says we may have to pull the fuel tank! We are not happy!
Tagged:

Comments

  • GilmonGilmon USAMember Posts: 18
    That should be a warranty issue? That said, if you look into your fuel tank compartment you will see a lot of excess plumbing and hardware to comply with government regulations. IMHO, this over engineering adds cost and potential problems. I'm not sure what the benefit is to our environment? 
    Regards, Capt. Gil
    2018 SW 186C
    20 HP Mercury ELPT (lake limit)
    Lake Nockamixon located in SE Pennsylvania
  • SteveandSylviaSteveandSylvia Member Posts: 4
    Went to dealer today. They are in the process of replacing all defective parts and supposed to deliver boat tomorrow. Time will tell but I think we will be happy with the boat now. Also, Gilmon, my brother said the same thing about the over engineering. Thanks!
  • gbownvagbownva Member Posts: 10
    I get the feeling that production is the top priority get the boats out and let the dealers deal with issues same as the RV industries no product control none their not watching during construction blind to potential issues get them out the door FAST!  
  • ThinBlueLineThinBlueLine Member Posts: 3
    any update? I had the same issue. bought my new tritoon in august, Honda 250, got to about 1/4-1/2 tank and it died. found the priming bulb sucked flat. squeezed it a bunch of times until it was full and hard again and then it would start. take off and it would run for about 2 mins then die again. same thing. if I ran it at about 1000-1200 rpm the bulb would stay flat but I was able to nurse it to dock (3 hrs later) tried opening the tank vent and gas cap but neither helped. took it back to the dealer and they couldn't find anything. filled it up and it ran fine again but i haven't got it below 1/2 tank. Im taking it out the 15th so will see what happens.

  • TomETomE Member Posts: 11
    I've seen that happen when the fuel tank isn't getting air.
    2007 Godfrey Sanpan 2500 FE
    Mercury 115 EFI
  • awloiselleawloiselle Member Posts: 1
    I have the exact same problem, boat runs for about 30 mins and then dies because it's starved for gas, the prime bulb is empty, prime until the bulb is hard and it will run 2-3 minutes until the gas in the line runs dry again. Have run it with the gas cap off, same result. By-passed the water/fuel fuel, same result. Blew out every line, same result. Totally frustrated. Any specific answer out there? Boat is a 2015 2086 with a 50 hp Yamaha. 

Sign In or Register to comment.